Repository pull task fails after an ePolicy Orchestrator upgrade (KB87407)

Repository pull task fails after an ePolicy Orchestrator upgrade (KB87407)

Environment
McAfee ePolicy Orchestrator (ePO) 5.x

Problem

After you upgrade ePO, a scheduled Repository Pull task or a Pull Now task fails immediately after initializing. The orion.log contains the following error:
 
2016-07-01 02:29:13,160 ERROR [scheduler-TaskQueueEngine-thread-2] service.ScheduledTaskManagerImpl  - execution of task Update Master Repository failed com.mcafee.orion.core.cmd.CommandException: The License Manager found an unknown license.

2016-07-01 02:20:53,899 ERROR [scheduler-TaskQueueEngine-thread-2] services.DownloadService  - SQL Exception trying to update products strings.
java.sql.SQLException: Violation of PRIMARY KEY constraint 'PK_EPOSoftwareCatalogStrings'. Cannot insert duplicate key in object 'dbo.EPOSoftwareCatalogStrings'. The duplicate key value is (1, label, 1033).

System Change

Upgraded ePO.

Cause

The cached file C:\Program Files (x86)\McAfee\ePolicy Orchestrator\Server\bin\mlcf_tomcat7 on the ePO server has become corrupted.

Solution

To resolve the issue, delete mlcf_tomcat7 and restart the ePO services:
  1. Delete the file C:\Program Files (x86)\McAfee\ePolicy Orchestrator\Server\bin\mlcf_tomcat7.
  2. Restart the ePO services to regenerate the mlcf_tomcat7 file:
    1. Press Windows+R, type services.msc, and click OK.
    2. Right-click the following services and select Restart:
       
      McAfee ePolicy Orchestrator x.x.x Application Server
      McAfee ePolicy Orchestrator x.x.x Server
      McAfee ePolicy Orchestrator x.x.x Event Parser